Network Latency

Incident Report for BroadMAX Networks

Resolved

This issue has been resolved.
Posted May 14, 2025 - 14:56 EDT

Investigating

We are currently investigating reports of network latency affecting our subscribers in the Downtown Miami, Coral Gables and Miami/South Beach areas.

Our engineers are working on the issue.
Posted May 14, 2025 - 08:49 EDT
This incident affected: Internet Services.