Intermittent issue with VoIP Phones

Incident Report for BroadMAX Networks

Resolved

The issue with our BroadMAX VoIP services has been resolved.
Posted Apr 14, 2026 - 23:19 EDT

Identified

Our team of engineers has identified the issue and is working towards a prompt resolution.
Posted Apr 14, 2026 - 16:33 EDT

Investigating

We are currently aware of and actively investigating an issue causing phones on the BroadMAX VoIP service to sporadically lose connection and reconnect after several minutes.
Posted Apr 14, 2026 - 11:42 EDT
This incident affected: Voice Services.